We have seen sustained recovery of our RPCs on Base mainnet and are marking the incident as resolved. Thanks for your patience as we worked through dealing with high load.
Posted Jul 30, 2023 - 19:55 UTC
Monitoring
We've implemented a fix the public RPC endpoint is now healthy.
As a reminder, the public RPC endpoint is *not intended for production use*. We recommend that you use any of the RPC endpoints available from dedicated providers. Please see our docs for recommended options: https://docs.base.org/tools/node-providers.
Also - a quick reminder: Base is open for *builders* and we're planning to open for everyone in early August. We appreciate everyone's patience as we bring Base into the world in a measured way.
Posted Jul 30, 2023 - 19:26 UTC
Identified
We believe high load on our RPC endpoints is causing timeouts and errors. We are working to bring the nodes back online in a state that can handle high load.
As a workaround for users and developers, RPC endpoints available from dedicated providers will still be functional. Please see our docs for recommended options: https://docs.base.org/tools/node-providers
Posted Jul 30, 2023 - 19:12 UTC
Investigating
We are observing elevated errors and timeouts for RPCs on Base network. We are investigating the cause and will update with details as we find them.