Elevated latency on Sepolia RPC

Incident Report for Base

Resolved

This incident has been resolved.
Posted May 13, 2026 - 16:52 UTC

Monitoring

We have temporarily decreased rate limits for this endpoint to ease traffic. Latency is moving back to normal on this endpoint.
Posted May 10, 2026 - 19:03 UTC

Identified

Latency on https://sepolia.base.org is high due to a node provider upgrade.
Posted May 10, 2026 - 18:31 UTC
This incident affected: Testnet (Public RPC API).