Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2025 - 18:00 UTC
Scheduled
Base is increasing the per block gas target from 29 Mgas/s to 30 Mgas/s as part of continued, planned scaling efforts to bring a billion people onchain.
For builders and almost all Base users, no changes are necessary. But if you're running a Base node and notice any latency after the increase:
1. Monitor CPU and Disk I/O usage 2. Enhance disk throughput and use disks with lower read/write latency (NVMe SSDs recommended) 3. Improve CPU, focusing on single-core speed
You can also stop by the #node-operators channel in the Base Discord (https://base.org/discord) if you have any questions and we'll be happy to help you there!
An upgrade and rollback script is included in each gas target increase in the event an unexpected issue is observed so that it can be reverted quickly if necessary.
✅ State growth
Node state growth is monitored each week to ensure long-term sustainability for node operators.
* Reth archive: 3.9TB * Geth full: 7TB
✅ Execution speed, block building and block latency
Execution speed has been within established guardrails indicated above over the past week.
* Sequencer has 100% uptime, building blocks, since last week’s target increase * >90% of blocks are built in two seconds or less
✅ All systems operational
All systems are operating within expected parameters to support this increase.
Posted Mar 26, 2025 - 00:01 UTC
This scheduled maintenance affected: Mainnet (Public RPC API).