Base Mainnet | Unsafe head delay

Incident Report for Base

Postmortem

On August 5th 2025, we experienced a 33 minute network disruption that halted block production on Base Chain Mainnet. We want to share what happened, how we addressed the issue, and the steps we are taking to prevent similar incidents in the future.

What Happened

To ensure high chain uptime and minimize single points of failure, we operate several sequencer instances in a highly available (HA) cluster. The cluster is managed by Conductor, an OP Stack component responsible for the reliability and availability of the system.

At 6:07am UTC, the active sequencer began to fall behind due to onchain activity. Conductor detected this and performed an automated handoff to a new sequencer, a standard procedure designed to maintain chain uptime. However, the new sequencer was in the process of being provisioned and was unable to produce blocks. 

Typically if an unhealthy sequencer is elected, it does another handoff. Since Conductor was not yet fully enabled on this sequencer, it was unable to initiate another handoff.

At 6:09am UTC, our monitoring systems detected this issue, and our team was paged to investigate. By 6:12am, an incident was formally declared, and our team began taking steps to resume block building.

How We Mitigated the Issue

Our team took the following steps to resume block building:

  1. Paused Conductor: We manually paused our HA software to prevent further automated leadership transfers.
  2. Started a healthy sequencer: We manually transferred leadership from the unhealthy sequencer to a healthy sequencer. Planning the transfer took several minutes to ensure we did not re-org the chain.

By 6:40am UTC, the network was fully recovered, resulting in a total downtime of 33 minutes.

What We’re Doing to Prevent This in the Future

System Improvements: 

We will be updating our infrastructure to ensure that when a sequencer is added to the Conductor cluster, it is always able to transfer leadership if elected.

Enhanced Testing: 

We will test and deploy these fixes as soon as possible to ensure the robustness of our automated systems.

Posted Aug 05, 2025 - 17:16 UTC

Resolved

The incident has been resolved
Posted Aug 05, 2025 - 06:41 UTC

Monitoring

Issue's been identified and fixed, we're now monitoring to ensure nothing else comes up
Posted Aug 05, 2025 - 06:40 UTC

Update

We are continuing to investigate this issue.
Posted Aug 05, 2025 - 06:39 UTC

Investigating

Base mainnet chain is currently stalled
Posted Aug 05, 2025 - 06:07 UTC
This incident affected: Mainnet (Deposits, Withdrawals, Block production, Flashblocks).