Community Explorer Options

Incident Report for Base

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 18:31 UTC

Monitoring

Blockscout and Basescan are currently experiencing intermittent issues alongside elevated network throughput. Their teams are aware and actively working on a fix.

The Base network itself remains fully operational and unaffected.

If you need an explorer in the meantime, here are a couple of alternative options:
https://base.thesuperscan.io/
https://base.dex.guru/

We’ll send updates as we receive confirmation that the issues have been resolved.
Posted Apr 23, 2025 - 15:46 UTC
This incident affected: Mainnet (Public RPC API).