High RPC latency and transaction inclusion times on Base Mainnet

Incident Report for Base

Resolved

Block building and RPC performance has returned to normal
Posted Oct 20, 2025 - 21:07 UTC

Identified

Base Mainnet is experiencing high RPC and transaction inclusion latencies, as well as periodic inconsistencies in block production times.
Posted Oct 20, 2025 - 18:58 UTC
This incident affected: Mainnet (Public RPC API, Block production).